展开

产品购买咨询:0851-85868541

贵阳戴尔直销中心
  • 解决服务器启动中出现报错的问题
    • 时间:2018-05-07 15:52
    • 来源:www.0851dell.com
    • 更多
  • 故障现象:

     

    所有配备有回写缓存的SAS RAID卡,包括ThinkSystem、System x及ThinkServer系列服务器机型,在启动过程中出现"Critical Message","Cache data was lost..."的报错 。

     

    注意:不同系列服务器机型报错界面有所不同。

     


    原因分析:

    配备有回写缓存的SAS RAID卡在进行写入数据操作时,数据会经过RAID卡缓存再写入到硬盘中。如果数据在未完全写入到硬盘时,服务器发生断电,缓存中未写入部分的数据可能会丢失。待服务器通电启动时,RAID卡自检发现有未完整写入的数据,即出现此报错。

     

    任何非正常关机都可造成此异常,包括:

     

    1. 停电;

     

    2. 手动强制关机;

     

    3. 服务器宕机。

     

    阵列卡缓存数据丢失可能导致操作系统出错、文件损坏,严重时可能造成阵列出错、掉线或者阵列卡进入安全模式。


    解决方案:

    当出现缓存数据丢失的报错时,通常只能忽略报错,并建议首先检查RAID状态。具体操作如下:

     

    在"Critical Message"界面将光标下移到"Enter Your Input Here:"处,按回车,在输入框中输入字母"A",再按回车;

     

     

    然后会提示"Critical Message handing completed. Please exit." 处理完成,按ESC键退出;

     



     

    接下来按字母"Y"键继续;

     



     

    随后服务器会继续POST及引导过程,建议在此时进入RAID卡配置界面查看RAID状态,如果RAID状态正常,可以继续正常引导。

     

    如果无法引导系统或者系统报错,可能是缓存数据丢失所导致,需要对系统进行修复或者重新安装。

     

    如果已按照上述进行操作,关机或者重启后依然出现"Critical Message"界面提示,则可能发生硬件故障,建议及时联系售后服务报修。

     

    一些可以降低发生缓存数据丢失问题的方案:

     

    1. 将Virtual Drive的Write Cache Policy设置为Write Through(直写模式),但此模式会明显降低RAID性能,特别是RAID5和RAID6;

     

    2. 加装、配备电池(BBU)或者闪存备份单元(Flash Backup Write Cache及Super Capacitor);

     

     

公司地址
贵州强川科技有限公司

贵州贵阳市云岩区中山西路腾达广场A栋23楼8号
邮编:550000

贵阳戴尔专卖店 | 戴尔笔记本 | 戴尔台式机 | 戴尔服务器 | 戴尔工作站 | 贵阳戴尔外星人专卖店 | 贵阳戴尔服务器| 贵阳服务器总代理
咨询热线:400-028-6620 传真:0851-85868541 QQ:2851705940 邮箱:gz@qiangchuan.com
版权 1999-2011 贵州强川科技有限公司 版权所有
地址:贵州贵阳市云岩区中山西路腾达广场A栋23楼8号